安装gitbook-pdf依赖出错

GitBook 是一个基于 Node.js 的命令行工具,可使用 Github/Git 和 Markdown 来制作精美的电子书。

之前已经通过npm install -g gitbook-cli命令安装了gitbook,但一直没安装gitbook-pdf依赖,所以一直在windows本地生成过pdf。

命令行输入:

1
npm install gitbook-pdf -g

然而出现了error:

此处输入图片的描述

仔细看提示可以发现,错误原因是因为phantomjs-1.9.7-windows.zip这个文件下载问题,后来到网上查一下才发现原来这个源被墙了【万恶的GFW!!!

然后就简单了,随便找一个phantomjs-1.9.7-windows.zip下载到本地,放在C:\Users\hwk603\AppData\Local\Temp\phantomjs里面。

这里提供一个下载链接:

phantomjs-1.9.7-windows.zip

回到命令行,再次执行:

1
npm install gitbook-pdf -g

此处输入图片的描述

安装成功!!!